Results 1 to 4 of 4
  1. #1
    Member
    Join Date
    Jan 2011
    Posts
    2
    Points
    0

    Default Engine Trouble, 1994 S-10

    I have a 1994 S-10, 4.3 V-6 Vortex, It jumps from OD to Dir. while driving, It also surges while parked about 400 RPM'S , up and down. Does anyone have a clue what to look for?

  2. #2
    Administrator Help2Go Administrator Canuck's Avatar
    Join Date
    May 2003
    Location
    Edmonton, Alberta, Canada
    Posts
    9,817
    Points
    2033

    Default

    We are mostly involved with computer problems here at Help2Go. One of our members may be able to help, but I think your best bet would be to go to an site that deals with auto fixes, like 1994 Chevrolet S-10 Repair, Maintenance & Service by FixYa


  3. The Following User Says Thank You to Canuck For This Useful Post:


  4. #3
    Member Spyware Fighter DonnaB's Avatar
    Join Date
    Apr 2009
    Location
    Illiana, Ill. USA
    Posts
    3,521
    Points
    563

    Default

    Sounds like a vacuum leak. My dad used to spray water on his intake manifold when it was cold, and if the water got sucked in he would say that he needed to replace the gasket.

    Not sure if that will help but it sure brought back memories for me.
    Last edited by DonnaB; 07-11-2011 at 09:21 PM.
    If you think you might be infected with malware or have recently cleansed your computer of malware without the help of an expert, please read and follow the instructions in How to Start Removing Viruses and Spyware from your Computer. This can alleviate time consumed in trouble shooting your current computer problems.

    If your problem is solved, here's how to say thanks!

    Very proud parent of a U.S. Navy "CB"



    "People may forget what you say,
    People may forget what you did,
    but People will never forget how you made them feel!"

  5. #4
    Member Spyware Fighter
    Join Date
    Jun 2010
    Location
    Bement,Ill USA
    Posts
    1,340
    Points
    146

    Default

    Hello,


    Sounds like a Speed sensor. Something similar to that was happening in my Chevy pickup. Would go way high on rpms and would go back and forth between passing gear. Thought it was my transmission ended up being a 70$ sensor
    " Extinguishing Malware from the world"

    The Spware Help forum is very busy. If I'm helping you and I've not posted back within 24 hrs., send a PM with your topic link. Thank you.
    HELP REQUESTS VIA THE PM SYSTEM WILL BE IGNORED. The Forums are there for a reason!
    Thanks-