Results 1 to 9 of 9
  1. #1
    pl
    pl is offline
    Member
    Join Date
    May 2006
    Posts
    37
    Points
    0

    Default SmallHeap Library msg

    I have installed some old software on a new laptop but when I try to open it I get a Window called SmallHeap Library carrying the message MEM_BAD_POINTER.
    What does it mean and what should I do, please?

    The old software is AutoCad14 - which installed and work sucessfully on my old laptop - and my new laptop is Dell Inspiron 1525 running MS Vista.

  2. #2
    Administrator Help2Go Administrator Canuck's Avatar
    Join Date
    May 2003
    Location
    Edmonton, Alberta, Canada
    Posts
    9,817
    Points
    2034

    Default

    From what I've read, your version of AutoCad is not compatible with Vista. See here .

    These versions supposedly do

    • AutoCAD 2002, AutoCAD 2004
    • AutoCAD 2007 with SP2
    • AutoCAD 2008 32 and 64bit
    • AutoCAD LT 2008
    Last edited by Canuck; 10-27-2008 at 03:45 PM.


  3. #3
    Moderator Forum Moderator arraknid's Avatar
    Join Date
    Dec 2006
    Location
    France
    Posts
    6,151
    Points
    1293
    Blog Entries
    4

    Default

    AutoCad 14 won't work in Vista without some tweaking.

    This will explain and give you links to replacement files.

    Another solution here.

    Good luck.

  4. #4
    pl
    pl is offline
    Member
    Join Date
    May 2006
    Posts
    37
    Points
    0

    Default Autocad14 and Vista

    Success!

    I insert the updated .dll file as suggested and it worked immediately.

    Thank you both very much.

  5. #5
    Moderator Forum Moderator arraknid's Avatar
    Join Date
    Dec 2006
    Location
    France
    Posts
    6,151
    Points
    1293
    Blog Entries
    4

    Default

    You are welcome. Pleased it worked out for you.

  6. #6
    pl
    pl is offline
    Member
    Join Date
    May 2006
    Posts
    37
    Points
    0

    Default

    Arraknid,

    Back in 2008 you solved a problem for me. It related to the use of old software on Vista, see above. The solution was to replace the existing sh31w32.dll with a version compatible with vista. I have need to do this again but the link you gave me ( http://www.windowsreference.com/wind...-r14-in-vista/) is no longer valid. I have looked unsuccessfully for another source.
    Are you able to help again, please?
    peter

  7. #7
    Member Spyware Fighter zep516's Avatar
    Join Date
    Dec 2005
    Location
    Pittsburgh, Pa
    Posts
    7,189
    Points
    1308

    Default

    Arraknid is unfortunately no longer with us.

    There maybe help here,

    https://forums.autodesk.com/t5/autoc...1892221/page/6

  8. #8
    pl
    pl is offline
    Member
    Join Date
    May 2006
    Posts
    37
    Points
    0

    Default

    Thank you for this Zep, I'll work through it and let you know the result. Meanwhile, can you explain why downloading the .dll file worked previously. Was is because the existing file was corrupted or was it because a Vista compatible version was required?
    best regards

  9. #9
    Member Spyware Fighter zep516's Avatar
    Join Date
    Dec 2005
    Location
    Pittsburgh, Pa
    Posts
    7,189
    Points
    1308

    Default

    I'd have to guess at that question and say because Vista compatible version was required.