Results 1 to 6 of 6
  1. #1
    Member
    Join Date
    Jan 2003
    Location
    Nyc, NY
    Posts
    261
    Points
    1

    Default pio mode doesnt seem to go away

    i believe windows turned the specific cdrw dvd drive on pio mode because i was trying to restore a music cd with errors on it. however i cant seem to get it back to dma mode. also, im not sure if this contributes to the issue. i cant find the ide primary/secondary in atapi/edie section in devices list. i mean i dont even have a category listing for edie/atapi whatever. i have to click unknown > then i find ide primary etc. etc. so im not sure if that contributes or not but i think i should mention it. ill also include a screen shot.

    windows xp home
    2.4ghz cpu
    80gb hdd
    cdrw dvdrom drive <- pio enabled one
    dvdrw cdrw drive
    http://cp.100ws.com/members/filemana...50aXRsZWQuSlBH

  2. #2
    Moderator Forum Moderator arraknid's Avatar
    Join Date
    Dec 2006
    Location
    France
    Posts
    6,151
    Points
    1293
    Blog Entries
    4

    Default

    Your link doesn't work without logon, but it shouldn't be a problem.

    First thing to try is to find the entry for the drive under Unknown, right click on it and select Uninstall. Confirm it and restart the computer. XP should detect the drive and reinstall it. Does that work?

  3. #3
    Member
    Join Date
    Jan 2003
    Location
    Nyc, NY
    Posts
    261
    Points
    1

    Default

    sorry that i confused you. i meant there is no catagory for idie/atapi drives. like most help sites say. go into your ide/atap catagory and change the advanced settings for dma mode. but the thing is i dont even have a catagory for ide/atapi*. the primary ide channel is listed in a different catagory which is called unkown. this new screen shot should work fine. http://www.geocities.com/theweirdstuff/Untitled.png
    so maybe now you see the issue. ive also tried to do like even ms says. to turn pio mode, press ok, open the ide channel and then put dma mode and press ok and reboot. i tried this twice and still nothing. so maybe now the "unknown" catagory thing will work.

  4. #4
    Member Help2Go Moderator
    Join Date
    May 2003
    Location
    Boston, MA USA
    Posts
    2,994
    Points
    931

    Default

    This script will help you.

    DMA reverts to PIO | Windows Problem Solver

  5. #5
    Moderator Forum Moderator arraknid's Avatar
    Join Date
    Dec 2006
    Location
    France
    Posts
    6,151
    Points
    1293
    Blog Entries
    4

    Default

    If that doesn't work, try the following, which should reinstall the generic drivers for your drives. To do that you need to access a folder that is usually hidden. To make it visible, do the following...

    Open your My Documents window and click on Tools on the menubar, then Folder Options. Next click on the View tab and select Show hidden files and folders. Just below that, uncheck Hide extensions for known file types. Click on Apply and OK.

    Now go to your Windows folder, and find a folder called inf. It'll look slightly faded compared to the rest. Open it and find a file called cdrom.inf, right click on it and select Install. That should do it.

    You should now go back and reverse the procedure to show hidden files.

  6. #6
    Member
    Join Date
    Jan 2003
    Location
    Nyc, NY
    Posts
    261
    Points
    1

    Default

    thanks partie the script worked! thanks again guys.