Page 1 of 2 12 LastLast
Results 1 to 10 of 12
  1. #1
    Member
    Join Date
    Dec 2009
    Posts
    9
    Points
    0

    Default Windows XP Pro Automatic Update Hangs on Boot up

    I have an unusual problem with Automatic updates. It use to work just fine, but lately I noticed that the computer was extremely slow to boot up. I looked in Event Viewer and saw the following error:

    Event Type: Error
    Event Source: Service Control Manager
    Event Category: None
    Event ID: 7022
    Date: 12/17/2009
    Time: 6:17:50 PM
    User: N/A
    Computer: STAN-107C7C526F
    Description:
    The Automatic Updates service hung on starting.

    I changed the setting in Services to Manual and now the computer starts normally. I still get my weekly alert for security updates in my task bar, however, if I go to the Windows update website, I will first need to change the service setting back to Automatic.
    I have tried SFC /scannow and even tried a full Windows repair...no luck.
    I've searched the web, and this site, but didn't find anything like this.
    I use SP3 and have all the latest patches...current firewall (ZA pro) virus protection (ESET NOD32) and Spyware (Webroot SpySweeper).

    By the way, Automatic update seems to eventually start in the Event viewer so it isn't that it doesn't work at all, just severely slows the computer down on bootup.
    Any ideas???
    BD

  2. #2
    Moderator Forum Moderator arraknid's Avatar
    Join Date
    Dec 2006
    Location
    France
    Posts
    6,154
    Points
    1293
    Blog Entries
    4

    Default

    There are lots of reasons why AU can be problematic. You've tried 2 of the most common solutions, so here are a few more....

    1. Try re-registering all Windows Update files. Type, separately, each of the following into the Run box and click on OK...

    REGSVR32 C:\WINDOWS\system32\wuapi.dll

    REGSVR32 C:\WINDOWS\system32\wuauclt.exe

    REGSVR32 C:\WINDOWS\system32\wucltui.dll

    REGSVR32 C:\WINDOWS\system32\wups.dll

    REGSVR32 C:\WINDOWS\system32\wuaueng.dll

    REGSVR32 C:\WINDOWS\system32\atl.dll

    2. Try going into Services and making sure that Background Intelligent Transfer Service is Started and set to Automatic.

    3. Try downloading Dial-a-Fix, save it to the desktop then extract it to it's own folder.
    • Open the folder and run Dial-a-fix.exe
    • 2 windows will open. Close the one in the background labelled Restrictive Policies
    • Check the box in section 1, Empty temp folders.
    • Check the box in section 2, Fix Windows Installer.
    • Check the box in section 3, Fix Windows Update.
    • Check the box in section 4, labelled SSL/HTTPS/Cryptography. The 4 boxes under it should be pre-checked
    • Check all boxes in section 5, labelled Registration Center.
    • Click Go
    • Click OK for any error messages if received.
    • Restart the computer when done.


    4. If still no joy, try running a chkdsk scan. Instructions here. Follow the section headed Manual steps to run Chkdsk from My Computer or Windows Explorer.

  3. #3
    Member
    Join Date
    Dec 2009
    Posts
    9
    Points
    0

    Default

    Thanks for the help.

    I re-registered all the files successfully except the REGSVR32 C:\WINDOWS\system32\wuauclt.exe.
    An error message came up that said:
    c:\windows\system32\wuauclt.exe was loaded, but the DllRegisterServer entry point was not found.
    C:\Windows\system32\wuauclt.exe does not appear to be a .DLL or .OCX file.

    Are you sure this file can be re-registered?

  4. #4
    Moderator Forum Moderator arraknid's Avatar
    Join Date
    Dec 2006
    Location
    France
    Posts
    6,154
    Points
    1293
    Blog Entries
    4

    Default

    OK, type cmd into the Run box and click on OK.

    In the window, type, or copy and paste, wuauclt.exe /detectnow and press Enter.

    Close the window and wait for around 5 minutes to see if Auto Update starts. Obviously, AU needs to be enabled.
    Last edited by arraknid; 12-19-2009 at 05:34 AM. Reason: modified for clarity

  5. #5
    Member
    Join Date
    Dec 2009
    Posts
    9
    Points
    0

    Default

    arraknid:
    I sincerely appreciate your help, but to be sure I understand what you want me to do...it appears you think that Windows Update doesn't ever start, thus the suggestion to run wuauclt.exe /detectnow. If my assumption is correct, then I'm not sure why I need to do this since Automatic Update DOES eventually start with the computers bootup...it just has an error message in Event viewer that says it hung and then further into the bootup it eventually does start...all the while severely slowing down the boot time needed before the computer is fully booted up. If I change the setting of Automatic Updates in Services to manual from Automatic, then the system boots normally and I get my weekly task bar alerts to security patches that need to be downloaded anyway.
    If I am wrong...sorry. Then I will run the wuauclt.exe /detectnow.

  6. #6
    Moderator Forum Moderator arraknid's Avatar
    Join Date
    Dec 2006
    Location
    France
    Posts
    6,154
    Points
    1293
    Blog Entries
    4

    Default

    Yes I saw that it eventually starts, but wanted to investigate/correct all of the standard settings that may have been causing the lag. By setting on Manual, you avoid the need to load up the update manager that automatically downloads updates, so the computer starts quickly. On Automatic, Windows loads the update manager that sits in the background waiting to download any updates that may be available without asking you.

    By all means try the wuauclt.exe /detectnow command, and if that fails, go to C:\WINDOWS\system32 and find the wuauclt.exe file. Right click on it and select Delete. As it's a system file, within a few seconds, a new version will appear at the bottom of the window. Then retry the wuauclt.exe /detectnow command.

    Let us know.

  7. #7
    Member
    Join Date
    Dec 2009
    Posts
    9
    Points
    0

    Default

    "On Automatic, Windows loads the update manager that sits in the background waiting to download any updates that may be available without asking you."

    That may be another reason that I don't want Automatic Updates set to Automatic...I don't like having the updates downloaded before I have had a chance to review them to see if I want them or not. Per Susan Bradley of Windows Secrets, it is better to just have the alert let you know that there are updates and then decide if you want them or not...like Genuine Advantage and IE8.
    So it sounds like I really shouldn't worry about changing it to Automatic. Just wonder why it started slowing down the bootup so much.
    By the way, I ran wuauclt.exe /detectnow and then went to Services and saw that Automatic Updates was started so I guess that means it is working properly, just very slowly if I change it to Automatic from Manual.

    I downloaded Dial-A-Fix, but haven't tried it yet...do you think I should?

  8. #8
    Moderator Forum Moderator arraknid's Avatar
    Join Date
    Dec 2006
    Location
    France
    Posts
    6,154
    Points
    1293
    Blog Entries
    4

    Default

    I have my machines set up to review all updates before downloading and just accept the critical updates. Occasionally, I'll pay a visit to the WU website for any others that I might need, but that's rare. All third party updates, such as drivers, I download from the relevant sites. I also don't want SP3, IE8 or WGA. There is the option to refuse any of those in the future, but MS always seem to find a way!!

    Running Dial-a fix won't hurt anything. It just checks for system problems and repairs when necessary. It may also improve things, so go for it.

  9. #9
    Member
    Join Date
    Dec 2009
    Posts
    9
    Points
    0

    Default

    Thanks, I'll give it a shot and report back if it helped.

  10. #10
    Member
    Join Date
    Dec 2009
    Posts
    9
    Points
    0

    Default

    Well Dial A Fix didn't hurt, but it didn't help either. Oh well.

Page 1 of 2 12 LastLast