Results 1 to 4 of 4
  1. #1
    Member Steph's Avatar
    Join Date
    Nov 2004
    Location
    London, UK
    Posts
    900
    Points
    53

    Default Secunia PSI 2.0 won't load

    Anyone else having trouble with Secunia recently?

    It's getting stuck at the "verifying internet connection" stage and nothing happens, it just won't load. (Obviously, there's nothing wrong with my internet connection).

    Any help appreciated.

    Thanks.

    Steph
    Today is the dawn of another error ...



    Intel Core i3-3240 @ 3.4GHz;
    RAM 8.0 GB;
    Windows 7 Home Prem SP1 64 bit
    Firefox; IE11

  2. #2
    Member Spyware Fighter DonnaB's Avatar
    Join Date
    Apr 2009
    Location
    Illiana, Ill. USA
    Posts
    3,114
    Points
    496

    Default

    Hi Steph,

    What I found below may solve your problem:

    It seems your issue may have to do with the version of PSI you may be currently running. Others have posted recently in this forum stating the exact same issue you have, and of those, some have downloaded the most recent version of PSI, v. 2.0.0.3001. This version seems to clear up the issue of being stuck at 'Verifying Internet Connection' issue you seem to be having.

    Uninstalling the older version (you can check this by right-clicking the system tray icon and clicking 'About') and installing the newest version should work.

    Get the latest version from the download link above at 'Download PSI' on this page.

    Several people have said that there was no notification that there is a newer version available here, so I hope this helps.

    XP Home SP3, PSI v. 2.0.0.3001

    joe schmoe
    Found at the Secunia Forums
    If you think you might be infected with malware or have recently cleansed your computer of malware without the help of an expert, please read and follow the instructions in How to Start Removing Viruses and Spyware from your Computer. This can alleviate time consumed in trouble shooting your current computer problems.

    If your problem is solved, here's how to say thanks!

    Very proud parent of a U.S. Navy "CB"



    "People may forget what you say,
    People may forget what you did,
    but People will never forget how you made them feel!"

  3. #3
    Member Digerati's Avatar
    Join Date
    Dec 2008
    Location
    Nebraska, USA
    Posts
    794
    Points
    241

    Default

    It really is a shame Secunia does not post the latest version number on their download page. As can be seen here, all it says is V2.0. You have to click on the Changelog link to see what is the latest. And it also a shame Secunia PSI UI does not have a way to find what version you have installed. You much right click the System Tray icon and select About.
    Bill (AFE7Ret)
    Freedom is NOT Free!
    Heat is the bane of all electronics!

    ─────────────────────

    Windows Expert IT Pro, 2007 - 2015

  4. #4
    Member Steph's Avatar
    Join Date
    Nov 2004
    Location
    London, UK
    Posts
    900
    Points
    53

    Default

    Thank you both for your replies.

    @ Donna
    Thanks for that. I left it for a day and then tried again and now it's working perfectly - maybe the servers were busy although from the forum link you posted it seems that this has been an ongoing problem for some time.

    I have v. 2.0.0.1003 - there are two more versions (2.0.0.2001 and 2.0.0.3001) but according to the link Digerati posted they just fixed minor bugs and there's no need to change if Secunia is working OK, which apart from yesterday's difficulty it is, so I haven't bothered updating.

    @Digerati
    Thanks for the link and the change log info, very useful. It's annoying to have to search for the version number though. I agree, it would be more useful to have it properly displayed.

    Steph
    Today is the dawn of another error ...



    Intel Core i3-3240 @ 3.4GHz;
    RAM 8.0 GB;
    Windows 7 Home Prem SP1 64 bit
    Firefox; IE11