Results 1 to 8 of 8
  1. #1
    Member
    Join Date
    Aug 2011
    Posts
    3
    Points
    0

    Default Horizontal lines across laptop screen

    Hello

    Since yesterday I have been experiencing a problem with my 2 year old Sony Vaio VGN-CR42. Whenever I start up the laptop, a lot of white horizontal lines appear on the screen at different places. The strange thing is that if I momentarily apply pressure to the frame around the screen (it's a different place each time), the lines disappear and do not reappear until the computer is re-started.

    Any ideas?

    Thanks!

  2. #2
    Member abseh1's Avatar
    Join Date
    Jul 2008
    Location
    Tampa Bay
    Posts
    2,319
    Points
    388
    Blog Entries
    2

    Default

    Can you attach an external monitor to your laptop and check the display?

    If you go into safe mode does it do the same thing?

    The reason being, sometimes it is a driver issue but seems to lean more toward a hardware issue in your description

    Also,
    It could be a loose connection.

    The only way to check would be to take the laptop apart to find the connection between the LCD and the motherboard
    Most users prefer a tech to do that type of repair on a laptop....it depends on your comfort and knowledge level

    Click here for your manual
    SIGNATURE...When I post info I assume you have already read this link
    How to Start Removing Viruses and Spyware from your Computer

  3. #3
    Member Spyware Fighter DonnaB's Avatar
    Join Date
    Apr 2009
    Location
    Illiana, Ill. USA
    Posts
    3,524
    Points
    563

    Default

    @ abseh1-- I agree with your post completely. My thoughts exactly.

    @ clearprop--You didn't happen to purchase an extended warranty that goes beyond the 2 years did you?

    And to add to abseh's advice and from my sisters personal experience:

    Ribbon cables come loose that could cause that and beings it is a laptop, they do get shuffled around a lot. Could also be a short in the cable and need to be replaced.

    What happens when you open and close the lid? I've seen this make the lines go away and after a Tech Shop reseated the ribbon cable it was fine.
    If you think you might be infected with malware or have recently cleansed your computer of malware without the help of an expert, please read and follow the instructions in How to Start Removing Viruses and Spyware from your Computer. This can alleviate time consumed in trouble shooting your current computer problems.

    If your problem is solved, here's how to say thanks!

    Very proud parent of a U.S. Navy "CB"



    "People may forget what you say,
    People may forget what you did,
    but People will never forget how you made them feel!"

  4. #4
    Member
    Join Date
    Aug 2011
    Posts
    3
    Points
    0

    Default

    Thanks guys. The display works fine with an external monitor. When I open and close the lid, most of the times nothing happens but sometimes if there were no lines they may reappear.

    I have quickly taken apart the screen bit of the laptop and checked the ribbon cable connection on the back on the LCD is secure. I guess I will now open up the rest of the computer and check the connection on the motherboard is secure as well. Is there any chance that the fault may lie with LCD screen itself?

    I'll let you know how the disassembly goes!

  5. #5
    Member abseh1's Avatar
    Join Date
    Jul 2008
    Location
    Tampa Bay
    Posts
    2,319
    Points
    388
    Blog Entries
    2

    Default

    It seems like the LCD screen....but the Graphic Card which is integrated with the motherboard is a part of your display system too
    SIGNATURE...When I post info I assume you have already read this link
    How to Start Removing Viruses and Spyware from your Computer

  6. #6
    Member
    Join Date
    Aug 2011
    Posts
    3
    Points
    0

    Default

    All cables seem tight inside. Time to experiment with a new LCD!

  7. #7
    Member
    Join Date
    May 2013
    Posts
    1
    Points
    0

    Default

    Hi guys
    I am experiencing the same problem.
    Clearprop, how did you solve your problem?

    When I apply pressure to the frame,
    the line go for some time and it reappears.

    Thanks in advance

  8. #8
    Administrator Help2Go Administrator Canuck's Avatar
    Join Date
    May 2003
    Location
    Edmonton, Alberta, Canada
    Posts
    9,817
    Points
    2034

    Default

    Hi muhammed237 ,

    As you can see, this thread is almost 3 years old, and since clearprop never got back to us to share the fix we are stuck. If you've followed the advice the others gave and it still doesn't work, and attaching another monitor (which works) you'd probably be looking at a new screen.

    If you wish to continue looking into this with us, please start a new thread and give us the info on your laptop and what you've done so far to try to correct the problem.

    Thanks.