Results 1 to 4 of 4

Thread: Flash drive

  1. #1
    Member
    Join Date
    Mar 2010
    Posts
    6
    Points
    0

    Default Flash drive

    For some unknown reason my computer has suddenly stopped recognizing my Ativa memory stick (my other memory sticks are fine).

    I have looked in Device Manager and opened Universal Serial Bus Controllers. I have then plugged the memory stick into the drive and it shows up as USB Mass Storage Device.

    Nevertheless, it still does not show up on the Computer - so I can't open or save to it.

    I have gone online to ensure that I have the correct driver - and am told that everything is ok!

    What else can I do?!!

  2. #2
    Member abseh1's Avatar
    Join Date
    Jul 2008
    Location
    Tampa Bay
    Posts
    2,319
    Points
    388
    Blog Entries
    2

    Default

    Which OS?

    They have their own controller chip and should not need a driver

    First

    Did you try another computer....they are only microchips and do fail
    You are suppose to use the safely remove hardware when you eject those things, otherwise they can get messed up

    ==================================================
    Second

    Try assigning a drive letter to it...
    (BTW: also, they are usually formatted as fat 32....if you find it try reformatting to NTFS)

    Click Start, click Control Panel, and then click Performance and Maintenance.

    (NOTE: If you do not see Performance and Maintenance, go to step 3.)

    1 Performance and Maintenance is displayed in Control Panel only if you use Category view. If you use Classic view, Performance and Maintenance does not appear.

    2 Click Administrative Tools, double-click Computer Management, and then in the left pane, click Disk Management.

    3 Right-click the drive, partition, logical drive, or volume for which you want to assign a drive letter, and then click Change Drive Letter and Paths.

    4 Click Add.

    5 Click Assign the following drive letter (if it is not already selected), either accept the default drive letter or click the drive letter that you want to use, and then click OK.

    ==================================================================================
    Third

    Open the control panel and then go to system, open the device manager and check the drive out for any problems.

    Sometimes, you have to open the plus signs and there could be a small yellow caution sign icon if there is a problem.

    You also may have the auto play configuration turned off
    Last edited by abseh1; 01-06-2013 at 08:40 AM.
    SIGNATURE...When I post info I assume you have already read this link
    How to Start Removing Viruses and Spyware from your Computer

  3. #3
    Member
    Join Date
    Mar 2010
    Posts
    6
    Points
    0

    Default

    Thanks abseh1

    Option 1 - not tried yet
    Option 2 - In "Add Drive letter and Path" , "Assign a drive letter " is greyed out so I cannot elect for this. It is showing D. I do have the option of selecting "Nothing in the following empty NTFS folder" but I don't know what to do or if will cause any damage!
    Option 3 - there are no yellow warning signs and I have elected for auto play.

  4. #4
    Member abseh1's Avatar
    Join Date
    Jul 2008
    Location
    Tampa Bay
    Posts
    2,319
    Points
    388
    Blog Entries
    2

    Default

    Try another computer
    SIGNATURE...When I post info I assume you have already read this link
    How to Start Removing Viruses and Spyware from your Computer