Results 1 to 3 of 3
  1. #1
    irvw
    Guest

    Default (Trident) video driver for Compaq Presario 1600 laptop

    :cry: I had to wipe my hard drive and start over with Compaq Presario 1600 XL1. I did not back up my drivers. HP website has the trident driver need for my display. However when I try to install I get error message saying I am not running on a Compaq Presario Platform. I've tried other drivers but nothing works. I'm running on Windows ME.

  2. #2
    Member Spyware Fighter Grim322's Avatar
    Join Date
    Apr 2004
    Location
    Glendale, Arizona
    Posts
    3,026
    Points
    718

    Default

    When you reloaded your OS, did you use the recovery disks that came from Compaq? If you did a new installation with ME, then it isn't a Compaq platform, even though it is a Compaq computer. See if you can find the driver from the Trident manufactuer or try www.driverguide.com

  3. #3
    Member Help2Go Moderator whoozhe's Avatar
    Join Date
    Jan 2001
    Location
    Wallaroo South Australia
    Posts
    8,567
    Points
    801

    Default

    As with ALL HP and Compaq machines they use propietry parts. The cards included with the system are modified for use in their machines only.
    You have two options here. One is to use the Recovery Disk which will bring the system back to the factory defaults. The second is install the OS and hope that the drivers will work, chances are they won't. You will find that at the card's manufactrer's site they will refer you back to HP for drivers.
    Buying HP, Compaq and IBM means you are locked in to them.
    Take control of your life. Leave others to control their own.