Page 1 of 2 12 LastLast
Results 1 to 10 of 11
  1. #1
    Member newcasper's Avatar
    Join Date
    Oct 2004
    Posts
    5
    Points
    0

    Default offline browsing for forum attatchments

    I tried a lot of offline browsers for downloading a section of a forum containing attatchments

    but no success for downloading any attatchment

    can u help me plz ?

    bye the way the forum type is vb as I think

  2. #2
    Member Help2Go Moderator whoozhe's Avatar
    Join Date
    Jan 2001
    Location
    Wallaroo South Australia
    Posts
    8,567
    Points
    801

    Default

    You need to understand the composition of a web site. Basically there are two elements. Page content and links.
    Some parts of what is viewed is not part of the actual page but is a viewable link to another site and/or area within the visited site.
    An example is many of the pics seen in this forum are stored in an area of the site only accessible by the owner.
    When you bring up the page, online, the link to this area is established and the pic is displayed.
    If the site is viewed offline that link cannot be made so no pic is displayed.
    This can apply to many elements of a web site including what you describe as attachments.
    Take control of your life. Leave others to control their own.

  3. #3
    Member newcasper's Avatar
    Join Date
    Oct 2004
    Posts
    5
    Points
    0

    Default

    thx 4 ur reply
    but it already gets the links which are stored in the page whatever it was pics or videos or any other type of files

    but what I am speaking about is the attached files which u add with ur reply from ur hard disk into the server not just making link for it
    thx again

  4. #4
    Member Help2Go Moderator
    Join Date
    May 2003
    Location
    Boston, MA USA
    Posts
    2,994
    Points
    931

    Default

    not sure if you know what SIDs are when using server side scripting, but I've tried a couple of Offline Browser programs also, and it seems like they are getting stuck on the session IDs (SIDs). The weird thing is, they aren't having problems following links which are also include SIDs but when it comes to actually recieving a file...it won't grab it because of the SID. When I got to a VBulletin forum and highlight an attachment, it doesn't show an SID on the link, BUT after saving the page with the Offline Browser program(s) and highlight that same link, it gives me a session ID in part of the link. Let's give you an example...

    Goto this address..
    http://freewebspace.net/forums/showthread.php?t=61215

    and look at the 9th post by Wojtek. There is an attachment there with the name recipes.xml.txt. If you just highlight it with the mouse and look in the taskbar of IE or your browser the link points to http://freewebspace.net/forums/attac...tachmentid=990 (notice no HTM extension). So I set my Offline Browser to download all links in the page http://freewebspace.net/forums/showthread.php?t=61215, it grabs the attachment.php file but the filename on my PC is attachment.php_s=321ad40d0d7c2512ab7b15ff8615d141&attachmentid=990.htm notice the _s= and the stuff after it before the &amp and the .htm extension. It's not the same link. Also, now that I think about it, it may also have something to do with MIME types also.

    Now, perhaps if you went to a VBulletin forum that has the rewrite engine on, then it MAY work. Usually what happens when someone uses the rewrite enigne in Apache, the php code is parsed (.php server side) and is THEN outputted as client side script in (.htm/.html). For a good example H2G I can only assume uses the rewrite engine for apache because this is a php based site but notice the address in the address bar, they end in .html. wowsers!

    I hope this was of some use, if not, I don't think I can explain it better lol.

    Partie™

  5. #5
    Member Help2Go Moderator
    Join Date
    May 2003
    Location
    Boston, MA USA
    Posts
    2,994
    Points
    931

    Default

    Here's a little add-on..

    I did a test on a post here on H2G located @ http://www.help2go.com/postt10273.html

    If you notice there's an attachment near the end of the 1st page of the topic. When I used my offline browser software to grab the page it actually downloaded that file.


    So I think it has something to do with PHP and Server Side Scripting.

    Partie™

  6. #6
    Member newcasper's Avatar
    Join Date
    Oct 2004
    Posts
    5
    Points
    0

    Default

    thx a lot for ur valuable help and answer

    I tried ur forum too and it was very easy to get the attatchment

    it seems that it differs from a forum to the other

    how abt this link

    http://www.iphone-forum.org/viewtopic.php?t=243

    I tried to download attatched files but with no success

    can u help ?

  7. #7
    Member Help2Go Moderator
    Join Date
    May 2003
    Location
    Boston, MA USA
    Posts
    2,994
    Points
    931

    Default

    my forum uses the rewrite engine :wink: it just doesn't output it in html, it strips the SID so web spiders like google are able to browse my server and get put up on search engines.

    I'll try your other link later. Right now I'm a little late for work lol

    Partie™

  8. #8
    Member Help2Go Moderator
    Join Date
    May 2003
    Location
    Boston, MA USA
    Posts
    2,994
    Points
    931

    Default

    So, I've finally was able to check out your link..

    http://www.iphone-forum.org/viewtopic.php?t=243

    If this is the forum that is giving you the trouble about downloading the files it's because they have it setup to where you have to logon to the forum to see the downloads/attachments. They aren't viewable by guests. unfortunately for you, since the offline browser is a different client you will have to logon from that client to view the attachments and since you can't without the correct logon form, you are unable to view the attachments. this is why you can't get those files.


    Partie™

  9. #9
    Member newcasper's Avatar
    Join Date
    Oct 2004
    Posts
    5
    Points
    0

    Default

    noooooooooo

    I am a member there
    and I type my user name and password in the fields asking me for that


    I did that b4 with another forum and it worked

    but did not work with this forum and another 2 ones

    may be they are doing some protection or something

    do u know anyway to hget these files with an offline browser?

  10. #10
    Guest

    Default

    Quote Originally Posted by newcasper
    noooooooooo

    I am a member there
    and I type my user name and password in the fields asking me for that
    Yes, I understand you are a member of that site, but what I am saying is that you are using Internet Explorer to logon to the site using your username and password, correct? The problem is, you're using a different client (your offline browser) to download the files and access the site and since your offline browser doesn't read the HTML forms to process your logon request you aren't logging into the site from the offline browser software hence the reason you aren't getting the attachments.

    No, I do not know of any offline browser packs that allow you to logon to the site or that will download attachments of that nature.

    Partie™

Page 1 of 2 12 LastLast