Results 1 to 8 of 8

Thread: MySQL 4.0.21

  1. #1
    Guesto1
    Guest

    Default MySQL 4.0.21

    I've been trying to install MySQL 4.0.21 on a WindowsXP Pro machine with SP2 loaded on it after installing Apache 2.0.50 and Php 5.0.2....everything got installed properly in C:\ except for MySQL. One should see a green light at the bottom right of the screen but it still shows as red. I tried restarting but it was of no use. Could anybody help please?

  2. #2
    Member Help2Go Moderator
    Join Date
    May 2003
    Location
    Boston, MA USA
    Posts
    2,994
    Points
    931

    Default

    What errors are you getting when you try to start the service? Also, look in the event viewer under the "applications" section, that might shed a little lite on what's going on. To get to the event viewer go into control panel then admin tools then event viewer.

    Partie™

  3. #3
    guesto1
    Guest

    Default Mysql installation issues

    This is the error I get in the event viewer:

    Can't find messagefile 'c:\apache\mysql\share\english\errmsg.sys'

  4. #4
    Member Help2Go Moderator
    Join Date
    May 2003
    Location
    Boston, MA USA
    Posts
    2,994
    Points
    931

    Default

    Sounds to me as if MySQL wasn't installed correctly. Sorta like MySQL is trying to show you an error yet it can't find the error file. Question, are you using one of those bundled softwares that come with apache+php+mysql like phpTriad ?

    IF you are, I've found that it's actually easier to setup all those different web servers/services seperately. It also helps you learn a little more about what you're doing when using them.


    Partie™

  5. #5
    mysql
    Guest

    Default

    Yeah it does appear that MySQL was not installed properly. I'm installing each of the softwares separately (without using PhpTriad, etc.) It did work on another machine running WindowsXP Pro SP2, I'm just wondering if there is any particular way to install MySQL if it didn't install properly....uninstalled and reinstalled quite a number of time.

    Do you know of any hidden files which may exist causing the fresh installation not to go through completely? bcuz when I try running the setup file....it goes from 0 to 99% in less than a second. The rest of the screens appear to be normal and after installation the size of the file is 67.08MB, does that seem normal to you?

  6. #6
    guesto1
    Guest

    Default from _setup.dll

    This is what I just saw in the _setup.dll file which is in the folder where the setup.exe file is located. What do you think?

    À À€H 5 Æ B Setup  Helv &   e € P‚Setup is preparing the %s Wizard which will guide you through the application setup process. Please wait.    Y P‚ÿY >  .    P€OK ~ ~ (   P€Cancel & - ’
    R P‚ Setup Initialization Error2000 Setup has failed to detect that SHARE is loaded. If you continue, you may experience file sharing related problem. Do you want to continue?iSetup is unable to locate the script file <%s> which is needed to complete the installation.

    Error 107.xSetup is unable to run a program needed to proceed with the installation. Restart your system and try again.

    Error 105.¢Setup is unable to find a hard disk location to store temporary files.

    Make at least %dKB free disk space available and then try running Setup again.

    Error 101.“Setup is unable to decompress and copy all of the program files needed to proceed with the installation. Contact your software vendor.

    Error 112.›Setup requires a different version of Windows. Check to make sure that you are running Setup on the Windows platform for which it is intended.

    Error 102.nSetup was started with a command line argument that contained an incomplete parameter quote '%s'.

    Error 110. ŽInsufficient memory available to run Setup. Close all other applications to make more memory available and try to run Setup again.

    Error 111.iSetup is unable to locate the layout file '%s' which is needed to complete the installation.

    Error 112.

  7. #7
    guesto1
    Guest

    Default thanks

    Well, it's not solved yet....but thanks a lot for your time and help

  8. #8
    Member Help2Go Moderator
    Join Date
    May 2003
    Location
    Boston, MA USA
    Posts
    2,994
    Points
    931

    Default

    how's your space on your hdd? Especially the temp folder? There's a free program called Crap Cleaner, not sure where I heard it from but it's a great program to clean up temp files and all other stuff not needed. I'ts installed on my system and it usually clears up 256mb + of temp files everytime I run it (which is everytime I restart the computer) Why not download it and run it real quick to make sure your temp folder isn't too full. You can download it from http://www.ccleaner.com

    Also, the _setup.dll file only relates to errors during setup, not actual MySQL errors.

    And one more thing, when you installed MySQL which server config did you use during setup? You might want to do a search for my.ini file (which should be in C:\windows\) and make sure the paths are correct. Also, taking a look at the mysql-d or mysqld-max file whichever you used to make sure the paths are correct. If in those folders the folder names have / instead of \ change them to \ to see if that helps.

    I'm going out of town here in a minute and I won't be back until sunday, hopefully someone will be able to help you more if the above doesn't help at all.

    Partie™