Page 1 of 2 12 LastLast
Results 1 to 10 of 13
  1. #1
    Member togoth's Avatar
    Join Date
    Jul 2005
    Posts
    6
    Points
    0

    Default dell wont turn on

    Please help I have a Dell latitude c600/c500 when I try to turn it on the lights come on like its going to start but then it stops. you can hear the harddrive start up but then it stops. it use to do it once and a while and when you pressed the power button a couple of times it would start. now it wont start at all. please help thank you in advance togoth.

  2. #2
    Member
    Join Date
    Feb 2005
    Posts
    546
    Points
    69

    Default

    Hello togoth, welcome to H2G.
    Are you trying to start using a mains power lead or just the battery power?
    it use to do it once and a while and when you pressed the power button a couple of times it would start. now it wont start at all.
    Seems to me that you have a problem that has been developing for a while.
    Can you remove the hard drive and try it in another computer? Apart from that I can't think of anything else to add.
    Regards guy9663.

  3. #3
    Member togoth's Avatar
    Join Date
    Jul 2005
    Posts
    6
    Points
    0

    Default

    hi thanks for the greating. I am using the battery and main ac adapter I also tried the harddrive in my other dell and it works fine. and yes its been an ongoing problem but I was hoping to find out what might be causing it and if its worth fixing it.thank you and if you can think of anything else let me know. togoth

  4. #4
    Member
    Join Date
    Jan 2003
    Posts
    12,000
    Points
    1191

    Default

    I just tried this on an old desk top.

    Disconnect all the drives and power up. Do you get anything on the screen?

    On the old desk top I did get info on the screen. I also tried had everything removed including the RAM. With everything gone, screen stayed black

    Cheers

  5. #5
    Member togoth's Avatar
    Join Date
    Jul 2005
    Posts
    6
    Points
    0

    Default

    this is a dell latitude c600 laptop and it wont power up at all whenyou press the power button the lights come on like its going to start but then they go out and nothing else happens.its like it gets power for a second but cant keep going.

  6. #6
    Member Help2Go Moderator
    Join Date
    May 2003
    Location
    Boston, MA USA
    Posts
    2,994
    Points
    931

    Default

    Did you happen to do what Basementgeek suggested by removing all unecessary components from it like the Battery, CDRom/Floppy drive, any PCMCIA cards? That will tell you if you have a problem with one of those items either pulling too much power or causing some other malfunction in the system. Also, you may want to check out on how to clear BIOS or reset BIOS on those systems. Not sure if you're lucky enough to have the watch battery style BIOS battery (old laptops) or if not then you have to short out a chip which I don't recommend for new users to do.

    Take a look on dells website for resetting that bios, i think it will be some kind of key combination without having the battery or AC adapter plugged in.

    Partie™

  7. #7
    Member togoth's Avatar
    Join Date
    Jul 2005
    Posts
    6
    Points
    0

    Default

    sorry it took so long to reply my job keeps me busy. yes I did try every thing that was suggested.but made no differance even dell cant come up with what is wrong. I appreciate the help though. thank you

  8. #8
    Member Bear's Avatar
    Join Date
    Oct 2004
    Posts
    1,839
    Points
    372

    Default

    My Sony Vaio laptop had a simular problem, it turned out to be a bad motherboard so I trashed it and bought this one I'm using now.
    Comptia A+ and Network + Certified. Microsoft MCP in Windows 2000 Pro. Server, Advanced Server and Data Center Sever.

  9. #9
    Member galena1's Avatar
    Join Date
    Oct 2003
    Location
    Devon -UK
    Posts
    3,109
    Points
    429

    Default

    Faulty power switch??
    I know everything about nothing, nothing about everything and precious little about the bit in between.
    P4-3.0G - Seagate Barracuda 160 - Maxtor 120 - Antec Hard Drive Cooler - 1GRam - Radeon9800Pro - Sony Multi DriveDVDRW - Audigy2 6.1 - XPHome

  10. #10
    Member
    Join Date
    Jan 2003
    Posts
    12,000
    Points
    1191

    Default

    galena1:

    Anything is possible, but this is not likely, since the PC does briefly try to start. Most power switches can be removed from the "circuit" after the PC starts and they continue to run. This is why you generally have to hold them in a couple of seconds, to turn it on, before you release them. Think of your car - You have to hold the key to start a couple of seconds to start the engine. Let go of the key and it continues to run.

    The power switch is not like a light switch, in that power is not always running through, it is signal for the MOB/ETC to start. Press it again and it is a signal to stop. (Granted we should use the software to do this).

    The poster needs to take the lap top in for repair I think. They are so hard to work on.

    Cheers :º)

Page 1 of 2 12 LastLast