Results 1 to 3 of 3

Thread: Need help

  1. #1
    Member carol_609's Avatar
    Join Date
    Nov 2005
    Posts
    2
    Points
    0

    Default Need help

    For the last two days I've been using my computer Im hearing a clicking noise in the cpu when it begins to load When I visit websites I hear the same noise and it slows down my pc from loading and sometimes I get a error saying that pg cannot be displayed. My icons go all white or black and the pc freezes alot now. I tried everything I could think of to do and now im all out of suggestions. Could someone please tell what the problem could be Thank You

  2. #2
    Member galena1's Avatar
    Join Date
    Oct 2003
    Location
    Devon -UK
    Posts
    3,109
    Points
    429

    Default

    Hallo Carol - Have you had a look inside the computer? It may be the cooling fan touching something or clogged up with dust. This may prevent satisfactory cooling of the cpu whch could lead to problems. Are you sure the sound is coming from the cpu? Check all the fans. I suggest you backup all important files folders etc. it may be a hard drive problem.Regards.
    I know everything about nothing, nothing about everything and precious little about the bit in between.
    P4-3.0G - Seagate Barracuda 160 - Maxtor 120 - Antec Hard Drive Cooler - 1GRam - Radeon9800Pro - Sony Multi DriveDVDRW - Audigy2 6.1 - XPHome

  3. #3
    Member billgates's Avatar
    Join Date
    Nov 2005
    Posts
    140
    Points
    24

    Default

    Hi Carol,
    Sort of on the same terms of gelena I would open up the computer and first check the fan(s). Make sure it is not rubbing on anything and is not full of dust and dirt. Then or maybe before your even check the fan I would back up your information just in case it is your hard drive. (better to be safe then sorry) Good Luck