Results 1 to 8 of 8
  1. #1
    Member
    Join Date
    Jan 2006
    Posts
    25
    Points
    0

    Default Option to change windows wallpaper is gone

    I have cleaned some viruses off our system but am still having some trouble. One of the characteristics was that the normal wallpaper was replaced by an ad for a spyware remover tool (how ironic). I ran the various clean up processes from my login (there are 4 accounts on this XP home system) and I think it was the automated HyjackThis detective that identified the final piece that allowed me to get control of my background again (when going into the properties dialog box from the desktop I had only 4 tabs instead of the normal 5 tabs - my background tab was gone). There was some type of registry setting that said something like "nobackgrounddisplayed". I did not think to write it down because I thought it would fix it for all users.

    We no longer get the ad for spyware as the background, but instead it is just black and we still cannot get the background tab for any of the other 3 users.

    The original background picture is still there because when we shut down it displays for a moment during the shutdown process.

    I have tried runing hyjackThis from another account and posting that log to the detective, but it does not find anything wrong.

    Is there a setting I can search for in the registry to fix this manually?

    Thanks,
    Carolyn

  2. #2
    Member galena1's Avatar
    Join Date
    Oct 2003
    Location
    Devon -UK
    Posts
    3,109
    Points
    429

    Default

    Hi - 'nobackgrounddisplayed' Are you saying you instructed HiJack to fix this by checking the box? Regards.
    I know everything about nothing, nothing about everything and precious little about the bit in between.
    P4-3.0G - Seagate Barracuda 160 - Maxtor 120 - Antec Hard Drive Cooler - 1GRam - Radeon9800Pro - Sony Multi DriveDVDRW - Audigy2 6.1 - XPHome

  3. #3
    Member
    Join Date
    Jan 2006
    Posts
    25
    Points
    0

    Default

    Yes, after the Hijack detective recommended checking that box I did and it worked at least for my account, but not the others. Now when I run Hijack on the other accounts the detective does not indicate anything is wrong.

  4. #4
    Member
    Join Date
    Dec 2002
    Posts
    12,000
    Points
    1191

    Default

    Long shot guess here:

    Start>Control Panel>Display>desktop>Customize Desktop>Web

    Anything there ? Try deleting it. Also is the lock box checked ?

    BG

  5. #5
    Member
    Join Date
    Jan 2006
    Posts
    25
    Points
    0

    Default

    Start>Control Panel>Display only shows tabs for Themes, screen saver, appearance, and setting. The virus did something that removed Desktop as a tab on the display dialog box. I figure that is how it set itself up as the display background and made it hard for the user to get rid of it.

    I have that tab back for my account, but not for the other accounts on the system.

    Thanks,
    Carolyn
    Carolyn

  6. #6
    Member galena1's Avatar
    Join Date
    Oct 2003
    Location
    Devon -UK
    Posts
    3,109
    Points
    429

    Default

    Hi cw - Two snippets picked up off the web. I suggest you set a 'Restore Point' before commencing

    1. Navigate to HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System
    and look for this entry in the right-hand pane:
    NoDispBackgroundPage with a Dword Value of 00000001
    If the key exists - and the Dword is also there - either delete it, or Modify its Value to decimal 0.

    2. Follow this link - http://www.kellys-korner-xp.com/xp_tweaks.htm
    Scroll down to number 128, right-hand side
    I haven't run this download but 1st link is XP Pro - 2nd link is XP Home. Regards.
    I know everything about nothing, nothing about everything and precious little about the bit in between.
    P4-3.0G - Seagate Barracuda 160 - Maxtor 120 - Antec Hard Drive Cooler - 1GRam - Radeon9800Pro - Sony Multi DriveDVDRW - Audigy2 6.1 - XPHome

  7. #7
    Member steamwiz's Avatar
    Join Date
    Sep 2003
    Location
    Yorkshire U.K.
    Posts
    14,022
    Points
    2335

    Default

    Hi

    #1 in Galena1's post can be fixed by following #2 in Galena1's post (no need for you to go into the registry)

    If running that reg file doesn't work for you, ( I think it probably will) then please do this :-

    1. download this zip file (to your desktop)

    http://www.help2go.com/modules.php?n...ownload&id=533

    2. unzip (extract) the zip file (to your desktop) to reveal a .bat file

    3. double click the .bat file - if you get a pop-up saying a script is trying to run... let it

    A black "DOS" screen will appear briefly, and then 2 text files will appear on your desktop (called 1.txt & 2.txt)

    open these files in notepad and copy their contents in your next post

    Also post a new hijackthis log

    steam
    Look here for Ways to keep your computer safe
    M'SOFT MVP -Windows Security 2004/8 .member ASAP -

  8. #8
    Member
    Join Date
    Jan 2006
    Posts
    25
    Points
    0

    Default

    Success!!! Running the tweaks and tips item 128 did it.

    Thanks so much for your help!

    -Carolyn