Results 1 to 2 of 2
  1. #1
    Member
    Join Date
    Mar 2007
    Posts
    1
    Points
    0

    Default external drive problem

    I have an external 40 GB Data To Go Drive by I/O MAgic that is a few weeks old. It worked for a few days after I backed up about 4GB of data. One day it just stopped. When I attached it to 5 different computers, the all give the Windows alert: USB Mass Storage Drive, Your New Hardware is Installed and ready to Use, the light comes on, but no one is home. It shows up In Device Manages as Mass Storage Device - This device is working properly.
    I have uninstalled and reinstalled the device. I have searched for an updated driver, the Driver I have is the most current available. I can even safely remove thie device from the computer.
    All this but Nothing under My Computer.
    When I right click on My Computer, Manage, Disk Management, The drive shows up w/o a letter, displays the wrong drive size also. The only right click option is Help.
    It is a laptop HD in a USB enclosure. I have tried a different cable, I have different USB devices that work fine on all my USB ports.
    The drive is a Samsung 5400 RPM made in 12/06. It is not spinning, I am going to try a different enclosure/connector as soon as I can . Any other suggestions out there? No, I didn't drop it.

  2. #2
    Member billgates's Avatar
    Join Date
    Nov 2005
    Posts
    140
    Points
    24

    Default

    I would guess from the information you provided you probably answered your own question, I would guess its either the enclosure kit, or the HD itself is not working properly. Good Luck though.