Results 1 to 8 of 8
  1. #1
    Member
    Join Date
    Mar 2006
    Posts
    56
    Points
    5

    Default DEP Options in Vista

    Running Windows Vista Business x86 and x64, this occurs on both platforms.

    When I go to the "Data Execution Prevention" tab in system properties - performance options, all the
    settings that can be changed are all grayed out. It then indorms me: To use these settings, you must be a computer administrator and you must use the bcdedit.exe file.

    Screenshot:
    http://img452.imageshack.us/img452/7...blemcx4cg1.jpg

    I am the administrator (using the built in admin account), now I know how to toggle DEP on and foff via the command line but is there any commands to toggle the status of DEP for specific applications, or better still any ideas on how I can retrieve the settings functionality back? Its really annoying as I have to now turn DEP off completley otherise many applicatiosn simply do not work.

  2. #2
    Administrator Help2Go Administrator Canuck's Avatar
    Join Date
    May 2003
    Location
    Edmonton, Alberta, Canada
    Posts
    9,817
    Points
    2034

    Default

    Funny you should ask this question, as I just saved an article on the very subject. Read on http://windowssecrets.com/comp/070503/ . Hope this helps.

  3. #3
    Member
    Join Date
    Mar 2006
    Posts
    56
    Points
    5

    Default

    Thanks for that, but I have read it, it just tells me how to use it, which I already know.

    I cant use it because the options are greyed out, they were not originally but something has caused them to, in both of my Vista platforms I am running. No new applications, or drivers have been installed which is why Im not sure what has caused it. Ive tried using other accounts and still the same thing.

  4. #4
    Member
    Join Date
    Mar 2006
    Posts
    56
    Points
    5

    Default

    Sorry I thought I had added a thumnail which allowed you to link to the full image, anyway added a link to the image.

  5. #5
    Administrator Help2Go Administrator Canuck's Avatar
    Join Date
    May 2003
    Location
    Edmonton, Alberta, Canada
    Posts
    9,817
    Points
    2034

    Default

    I haven't got into Vista yet (my wife's laptop has it, and to this point she's not asked for help!!) but have come up with a possible solution. Have you tried this http://www.vistaforums.com/FORUM/Topic587-9-1.aspx . I'm sure others will come to the rescue.

  6. #6
    Member
    Join Date
    Mar 2006
    Posts
    56
    Points
    5

    Default

    Thanks again, but yeah thats what I use to turn DEP on and off, the fact that the options are greyed out led me to believe that DEP was still off but its not the oepratin in the command line does complete successfully and applications that dont work with it fail again and the DEP message is displayed by windows, so I know it does come back on.

    Yeah Vista is a good operating system although may people will tell you otherwise. This is the first problem I have had since mid January, even x64 was a breeze.

    Anyway again thanks for your help, hopefully someone will know somewhere.

  7. #7
    Member
    Join Date
    Mar 2006
    Posts
    56
    Points
    5

    Default

    Ive managed to fix it, found another command to use which none of the sites seem to tell you when telling you how to enable/disable via the command line.

    bcdedit.exe /set {current} nx AlwaysOn
    bcdedit.exe /set {current} nx optin

    Then restart!

    This has worked for x64, going to try it now in x86, thanks for you help though Canuck.

  8. #8
    Member Bear's Avatar
    Join Date
    Oct 2004
    Posts
    1,839
    Points
    372

    Default

    Jigsaw, thanks for posting the solution. That will help us if someone else has this problem in the future. We can simply point them to this thread for the solution. Thanks again