Its a thing that needs troubleshooting, first you need to try the steps we have suggested, then come back with the results of these steps, and any furrther info you can supply.

unfortunatly this is not something we can say , click 'a' then plug in 'b' and 'c' will come on and all will be ok.

first try the steps zep suggested, after making sure you have discharged any static, then post back with the results.

1, unplug and re attach all cables to your tower, this includes mouse, keyboard, power etc.
check to see if problem is solved, if not, goto step 2

2, open the side of your tower, and remove and re-insert all components including the graphics card (if aplicable) any sound cards (if aplicable) any memory sticks and the connectors to your harddrive and any other devices (floppy drive, second harddrive etc). check to see if the problem is solved ( i recomend you remove and re-insert one thing at a time, so you remember where each lead goes)

3, if you have 2 ram sticks, remove 1, and try rebooting, then try the other with the first removed.

Let us know what the results of these steps are, and we will assist you further.

should you be uncomfortable with any of these steps, post back for a better explanation, and more advice.

We will do our best to help, but we need to know the answers to these steps before we try anything else, even if the answer is you are not confident enough to take these steps.

Mr Darn