Results 1 to 8 of 8
  1. #1
    Moderator Forum Moderator arraknid's Avatar
    Join Date
    Dec 2006
    Location
    France
    Posts
    6,151
    Points
    1293
    Blog Entries
    4

    Question An interesting problem

    Today we had to sort a laptop that had the C:\windows\system32\config\system missing or corrupt problem. Our normal approach is the Microsoft way, but that failed, so I directed the young guy working on it (a one year veteran!) to this site and told him to follow Partie's instructions to the letter. 3 hours later, I found him, head in hands, cursing and swearing under his breath. His problem, which we've actually come up against before, is the inability on a french laptop to type a tilde (~) in Command Prompt. He'd tried everything he could think of and searched the net for possible answers without result. To save wasting more time, he did a repair install and all was back working an hour later.

    My question is, does anyone know how to get around this? The problem, as far as I can tell, is that the tilde is used as an accent in the french language, and under normal circumstances, would wait for another character to be entered....a 'u' for instance, to complete the sequence.

    Maybe a question for Partie.

  2. #2
    Administrator Help2Go Administrator Canuck's Avatar
    Join Date
    May 2003
    Location
    Edmonton, Alberta, Canada
    Posts
    9,817
    Points
    2034

    Default

    Have you tried copy and paste from the Character Map in Accessories > System Tools?


  3. #3
    Member MrDarn's Avatar
    Join Date
    Jul 2007
    Location
    South East Northumberland
    Posts
    2,949
    Points
    557

    Default

    is this it? ~?

    if so, my command prompt does one no problem by holding shift and pressing the # key.

    if its not an english layout keyboard, perhaps changing it to english layout is a workaround?

    my # (and therefore ~) key is to the left of the enter key on the central letter stack, and to the right of ' (shift + ' = @)

  4. #4
    Moderator Forum Moderator arraknid's Avatar
    Join Date
    Dec 2006
    Location
    France
    Posts
    6,151
    Points
    1293
    Blog Entries
    4

    Default

    Thanks Canuck.......we couldn't get into Windows. We were working in Recovery Console on Command Prompt.

    Mr Darn......it works OK if using an english keyboard, but not a french one. How do we change to an english layout outside Windows?

  5. #5
    Moderator Forum Moderator arraknid's Avatar
    Join Date
    Dec 2006
    Location
    France
    Posts
    6,151
    Points
    1293
    Blog Entries
    4

    Default

    After thinking about it more, I found a way around the problem. I attached a french usb keyboard and used Alt+126 on the number pad. Strangely, it wouldn't work on the laptop's keyboard using Fn + Alt +126. As I said, the problem is resolved now, but I'll know in future.
    Last edited by arraknid; 07-17-2008 at 01:38 PM. Reason: errant sentence removed!

  6. #6
    Member MrDarn's Avatar
    Join Date
    Jul 2007
    Location
    South East Northumberland
    Posts
    2,949
    Points
    557

    Default

    i may be reading you wrong, but my understanding of it is your number pad is incorperated into your keyboard, so J=1 K=2 L=3 ect, but to activate the number pad you have to hold Fn and press F11?

    if that is the case, you shouldnt need to hold Fn when you do the Alt 126, once the number pad is active. the Fn key is only used in that sequence if the number pad is disabled, ie when you press the J key alone, you get a j.

    if the number pad was active, pressing J alone would produce a 1, releasing the need for the Fn key to be used.

    i think i even confused myself there! lol

  7. #7
    Moderator Forum Moderator arraknid's Avatar
    Join Date
    Dec 2006
    Location
    France
    Posts
    6,151
    Points
    1293
    Blog Entries
    4

    Default

    Exactly right Mr Darn. Well spotted. I wrote a little more than I posted and edited it very badly. I meant to delete the sentence about the keypad being activated, but missed it.

  8. #8
    NM
    NM is offline
    Member
    Join Date
    Apr 2008
    Location
    Barbados
    Posts
    75
    Points
    9

    Default

    A handy site for those unusual letters/characters http://www.asciitable.com/

    ñ (= ALT+164) ¿Si, señor?
    Norbert